While I try my best to ensure the accuracy of every blogs posted, I cannot guarantee that it will suit your environment or platform. © Copyright 2008-2024 JackNg C. H.. All Rights Reserved.
Remove unwanted Solaris packages (Rev: 1.1)
After installing a full Solaris 10 5/2008 operating system (SPARC) with OEM support packages to the SUN Fire 280R server, I created a simple script (jrmpkg) to remove those packages that I did not want to free up hardisk space. You can copy and paste the below jrmpkg codes, and save it as any filename at your Solaris 10 machine. Modify the codes as you wish before running it.
------------- BEGIN jrmpkg codes -----------------------
#!/bin/csh
# Jack, Aug 2008, Rev: 1.0
# Remove unwanted packages for Solaris 10 5/2008
# Russian 1251 fonts
pkgrm -v SUNW1251f
# Apache common logging
pkgrm -v SUNWaclg
# Apache Web Server
pkgrm -v SUNWapch2d #V2 Documentation
pkgrm -v SUNWapch2r #V2 root
pkgrm -v SUNWapch2u #V2 usr
pkgrm -v SUNWapchd #Documentation
pkgrm -v SUNWapchr #root
pkgrm -v SUNWapchu #usr
# Boot server daemons
pkgrm -v SUNWbsr #root
pkgrm -v SUNWbsu #usr
# Solaris Diskless Client Management Application
pkgrm -v SUNWdclnt
# DHCP
pkgrm -v SUNWdhcm # DHCP manager
# Binary file format data module for BOOTP/DHCP services
pkgrm -v SUNWdhcsb
pkgrm -v SUNWdhcsr # BOOTP/DHCP server services (ROOT)
pkgrm -v SUNWdhcsu # BOOTP/DHCP server services (USR)
# CDE demos
pkgrm -v SUNWdtdem
# FTP server
pkgrm -v SUNWftpr #root
pkgrm -v SUNWftpu #usr
# Gnome games
pkgrm -v SUNWgnome-games
pkgrm -v SUNWgnome-games-root #platform dependent files, / filesystem
pkgrm -v SUNWgnome-games-share #platform dependent files, /usr/share
# J2SDK 1.4 demo programs
pkgrm -v SUNWj3dmo
# JDK 5.0 demo programs (1.5.0_16)
pkgrm -v SUNWj5dmo
# A set of Java Demo Applications
# jdictionary, jdiskreport. jedit, jgraphpad and jspider
pkgrm -v SUNWjavaapps
# JavaHelp demos
pkgrm -v SUNWjhdem
# Japanese iconv modules for UTF-8
pkgrm -v SUNWjiu8
# Japanese required TrueType font
# Solaris 10 5/2008 did not has this package
pkgrm -v SUNWjxcft
# Japanese required Bitmap font
pkgrm -v SUNWjxmft
# Korean iconv modules for UTF-8
pkgrm -v SUNWkiu8
# Korean TrueType fonts
# Solaris 10 5/2008 did not has this package
pkgrm -v SUNWkttf
# Korean X windows platform required fonts
# Solaris 10 5/2008 did not has this package
pkgrm -v SUNWkxfnt
# Korean (UTF-8) X windows platform minimum required fonts
pkgrm -v SUNWkxmft
# Modular debugger demo source
pkgrm -v SUNWmdbdm
# Mozilla for Solaris
pkgrm -v SUNWmozapoc-adapter #Apoc adapter
pkgrm -v SUNWmozchat #Chatzilla
pkgrm -v SUNWmozdom-inspector #DOM inspector
pkgrm -v SUNWmozgm #GNOME integration
pkgrm -v SUNWmozilla #Web browser
pkgrm -v SUNWmozilla-devel #Web browser - developer files
pkgrm -v SUNWmozjs-debugger #Javascript debugger
pkgrm -v SUNWmozmail #Mail
pkgrm -v SUNWmoznspr #Netscape portable runtime
pkgrm -v SUNWmoznspr-devel #Netscape portable runtime - developer files
pkgrm -v SUNWmoznss #Network security services
pkgrm -v SUNWmoznss-devel #Network security services - developer files
pkgrm -v SUNWmozpsm #Personal security manager
pkgrm -v SUNWmozspell #Spelling checker
pkgrm -v SUNWthunderbird #Thunderbird email/newsgroup client
# OS demo source
pkgrm -v SUNWosdem
# Open source demo programs
pkgrm -v SUNWsfwdemo
echo Disable sendmail process before removing sendmail packages
/usr/sbin/svcadm disable svc:/network/smtp:sendmail
# Sendmail
pkgrm -v SUNWsndmr #root
pkgrm -v SUNWsndmu #usr
# Thai (UTF-8) iconv modules for UTF-8
pkgrm -v SUNWtiu8
# Thai X windows platform required fonts package
pkgrm -v SUNWtxfnt
# Telnet server
pkgrm -v SUNWtnetc #client
pkgrm -v SUNWtnetd #server daemon (usr)
pkgrm -v SUNWtnetr #server daemon (root)
# X window system demo programs
pkgrm -v SUNWxwdem
# X window system demo images
pkgrm -v SUNWxwdim
------------- END jrmpkg codes --------------------------
To check all the software packages installed in your machine and save it as a file calls pkg.txt,
# pkginfo > pkg.txt
Browse through the text file pkg.txt to see the installed software packages,
# more pkg.txt
To display software package (eg: SUNWgnome-games) information in long format,
# pkginfo -l SUNWgnome-games
Reference:
[1] Sun Microsystems Documentation
Subscribe to:
Post Comments (Atom)
Please donate. Thanks.
paypal.me/jackngch
(PayPal-to-Paypal account only)
Popular Posts
-
If you spend long hours looking at your pc monitor screen daily, you might want to protect your eyes by changing the background colour o...
-
There are 3 partitions in the Dell Optiplex 9010 pc [Intel Core i7-3770 (3.40 Ghz) CPU, 32 GB DDR3 1600 Mhz memory, 1 TB SATA hardisk dr...
-
Assume running Windows 7 Enterprise x86 Operating System (OS) and had already installed the original RTM version (10.0.26624.0) of Window...
-
Microsoft KB2592687 is the Remote Desktop Protocol 8.0 update for the Windows 7 SP1 Operating System (OS) and Windows Server 2008 R2 S...
-
After login to the Windows 7 Home Premium x64 Operating system (OS) of the Acer Aspire X5900 pc [Intel i5-650, 3.20 GHz, Western Digital ...
-
I had bought the Roman Duo DeliCooker HL-400 ( S$1288.00 including 7% GST & delivery) on March 2014. I had found a Vees Electric Ho...
-
Diagram 1: Capacitor voltage (V C ) and current (I) waveforms In a capacitor, current (I) flows across the capacitor leads the capacitor v...
-
If you are searching for information on a mobile phone number, it will not be freely available in the public domain databases because of ...
-
Situation When I tried to add the " Chinese (PRC) - Chinese (Simplified) - Micosoft Pinyin IME 3.0 " keyboard layout to the Langua...
-
During SolidWorks 2019 SP2 installation, the below error message pop-up: SOLIDWORKS Installation Manager Microsoft SQL Server failed to...
No comments:
Post a Comment